• Không có kết quả nào được tìm thấy

After Effects and Photoshop: Animation and Production Effects for DV and Film - Second Edition

N/A
N/A
Nguyễn Gia Hào

Academic year: 2023

Chia sẻ "After Effects and Photoshop: Animation and Production Effects for DV and Film - Second Edition"

Copied!
386
0
0

Loading.... (view fulltext now)

Văn bản

Title to the Software and all related proprietary rights remain with WPI and its licensors. This limited warranty is void if failure of the software media has resulted from accident, misuse, or misapplication.

Connecting Photoshop, ImageReady, and After Effects 1

Basic ImageReady Animation, Tweening, and Layer Styles 3 Turning Photoshop Layers into Frames

This book is based on how both applications work together - and how you can get the most out of that union. NOTE: Most of the projects in this book require the latest professional versions of these applications.

Who Should Use This Book

What’s Inside

The appendix is ​​full of references for other After Effects and Photoshop training and reference resources, as well as contact information for third-party vendors and providers of stock photos, video footage, and plug-in effects used in this book.

The Companion DVD

How to Contact the Author

Basic ImageReady Animation, Tweening, and Layer Styles Chapter 2 Photoshop Layers and After Effects

3-D Layers from Photoshop Layers

These animations can be exported as uncompressed QuickTime movies that you can import into After Effects.

Turning Photoshop Layers into Frames

It will give you a better idea of ​​the current flow and animation in real time than the Playback button in ImageReady, and you don't need to export the animation to a QuickTime movie just to preview the timing of the animation sequence.

The Animation Palette in ImageReady

Move the object onto a single layer using the animation palette and click the Duplicates Current Frame button. Note: More information about tweening can be found later in this chapter in the animation palette.

Exporting Animation Files from ImageReady

In some cases, you may want to use the animation frames as separate images that you can work on or import into another application. You can do this easily by selecting File ➔Export ➔Animation frames as files, where you can select various file naming and compression options from the dialog box.

Pre-Animation: Painless Tweening in ImageReady

Tweening Motion

Click the Play button on the Animation palette to preview the motion path created by tweening, as shown in Figure 1.14. For a quick preview of the animation (and timing), select the Preview button in the default browser in the toolbar.

Tweening Effects

Select two frames in the Animation palette and click the Tween button to open the Tween dialog (Figure 1.17). Select the Reverse Frames option from the Animation palette menu to create a closed "loop" animation (Figure 1.18).

Applying Depth and Realism to Animations

Styles in Motion: Neon Text

Your final image should have a soft glow around the edges of the tube (See Figure 1.23). Set the opacity of the color overlay to about 30% and apply a slight drop shadow, as shown in figure 1.24.

Light in Motion: Leaf Shadow

Angle -120º Creates the illusion of a light source coming from below and moving upwards. I chose to add .1 Sec a few frames towards the end of the animation sequence to "fade in" to the last frame and then hold the last frame for 2 seconds before easing back in (Figure 1.30).

Pattern in Motion: Rolling Eye

Select the transparency of the modified layer (F+click/Ctrl+click in the Layers palette and invert the selection) and copy/paste the eyeball portion of the background. Open the layer style editor on the eyeball layer and choose the Pattern Overlay option.

Basic Layer Transfers

Go back to your After Effects project and select the layer(s) in the edited file and choose File > Reload Footage from the menu (Shift+F+L/Shift+Ctrl+L). NOTE : If you're importing a layered Photoshop file as a composition and don't need the layers scaled down drastically for extreme zoom, simply double-click the composition file After Effects creates for you in the Project window.

Transferring Layers with Style Effects

Importing this example file with a rendered layer and a layer with style effects applied shows how the effects will not transfer correctly unless they are rendered first (see Figure 2.7). This will give all the style effects in motion, but will also flatten the file so that no editable layers remain (see Figure 2.8).

Displacement Maps: Static Layers in Motion

Creating a Displacement Map

The water image you apply the displacement map to is a perspective view, so you can control the amount of movement towards the back of the scene (or the top of the image window) by adding a Solid Color Fill layer with a soft gradient mask (Figure 2.11). To further enforce the illusion of depth, resize the image to 480 pixels for a final dimension of 720 × 480 pixels.

Applying a Displacement Map

This allows for start and end points for the movement of the displacement map image. Run a RAM sample to test the displacement map effect animation and adjust the speed and pixel displacement as needed (Figure 2.17).

Masking and Adjusting a Displacement Map

Layers in Motion

Create a new composition, 640 × 480 NTSC (6 seconds long), drag the composition file from the Camera Roll from the Project window to the Comp 1 window, and resize the layer to 70% (Figure 3.1). Drop the settings for the layer into the timeline window and open Material Options.

Parenting the Layers and Adding Text

When the Light Settings dialog appears, select Spot as the Light Type and select the Casts Shadows checkbox. Note: For a more natural light, add some yellow or orange tint to the light source.

Positioning Lights and Layers

Move the indicator to the 3-second mark, select the movie text layer in the timeline and click Position Stopwatch. Move the indicator to the first frame on the timeline and set the Z-axis of the movie text layer to –890.

Animation with a Camera in Motion

Setting Up a Camera

Preparing the Layers

Check the distance from the first layer and the camera in the left view. Place a static layer of the branch near the camera so it will move past in the animation.

Animating the Layers

Open the material settings options in the timeline and turn on the Casts Shadows option.

The Rotation Tool: The “Axis of Evil”?

Adding Lights

Duplicating Layers in Motion

Reposition the camera and its point of interest from the left side view window down to the background layer to get an idea of ​​the starting angle for the animation (Figure 3.30). Be sure to space them out so that they are not too close together, and leave enough space for the other elements to pass through in animation (Figure 3.32).

Putting the Camera in Motion

Cause and Effect

Exaggeration Equals Characterization

The effects of gravity, recoil, drag, friction, inertia, and collisions are all around us every day.

Gravity: The Freefall

Return to the timeline window and move the indicator to 1:03 (three frames past the 1-second mark). Move the pointer on the timeline window to the 1:03 mark, where the starting point of the freefall will start the motion blur.

Gravity: Smooth Landing

Halfway between the landing point and the end of the slider, set the rotation label for both layers to -10º (Figure 4.8). A slight rotation at the end of the flight path establishes the perspective of the ground surface relative to the aircraft.

Gravity and Collision: The Bounce and Hang Time

Click on the stopwatch to create a marker and set the blur length to 25 pixels, leaving the direction at the default position of 0º. Move the indicator to the Frame 18 position and set the blur length to 0 there as well (Figure 4.11).

Gravity and Recoil: The Yo-Yo

Move the indicator to the 1 second mark and move the cord layer to the right side of the winding. This will allow the string to move from side to side, unwinding and winding back onto the yo-yo.

Inertia and Friction: What a Drag!

Place the chair layer outside the Comp 1 window frame and set the position stopwatch to Frame 0. Duplicate the chair layer in the timeline window (F/Ctrl+D) and hide the original chair layer.

Complex Animations: Combining the Techniques

Deselect all layers except the scale layer and press the R key to bring up the rotation settings and click on the stopwatch. Run a RAM preview to make sure the motion blur of all layers is in sync.

Make Your Work Easier Visually

You will need to apply any or all of the techniques used in this chapter to decide how each piece will move and bounce, rotate and slide (Figure 4.24). This will add dimension and movement in the focal point of the animated subject (Figure 4.25).

The Classic Sudden Stop

Apply the transform effect to the motorcycle layer (Effect > Distort > Transform) and set the Skew to 20 at an angle of +90º. To make the motorcycle appear to lean forward under the force of inertia, the timing of the lean is important.

Bouncing and Falling: Defying the Rules of Gravity

This will set the keyframes for the basic motion path of the animation (Figure 5.7). Set the keyframes for scale and position in the bounce and fall of the pineapple.

Rubber Planets: 3-D Animation Effects

  • Earth Stop
  • Mars Bounce
  • Moon Pop-Up
  • Saturn Drop

Click the anchor point crosshair button (called the Pan Behind tool in the toolbar) and set the crosshair in the lower left corner of the layer in the Comp window (Figure 5.13). Run the RAM preview to verify that all keyframes are correctly placed in the Earth animation.

Completing the Scene: Adding Lights

Switch to the front side view window and drag the Spot wire frame to the left side, just above the 8 o'clock position. Move the focus to the position to closely match the original position of the Sun with the planet image layers.

Kinematics: Human Figure Character Animation

Select each planet layer in the timeline, open Material Options and enable the Casts shadows option (Figure 5.27). From this point we work from the upper body through all the limbs.

The Knee Bone’s Connected to the Leg Bone

If you rotate the upper torso slightly, you will need to rotate the spine, lower torso, and legs to bring the feet back to the ground (Figure 5.31). By making adjustments to all the limbs from this position, you can begin to imitate graceful movements (Figure 5.32).

Kinematic Animation Example

Details in Kinematic Animations

Blue-Screen Garbage Mattes

Static Matte “Painting” in Photoshop Chapter 11 Motion Mattes in Photoshop

Making Movies from Stills

Blue screen and green screen compositing has become increasingly popular, with higher quality prosumer DV cameras and video editing software becoming more accessible. But sometimes things get in the way; you want to edit out something that falls in front of or next to your blue screen.

What Is a Garbage Matte?

A Blue-Screen/Green-Screen Primer

The Static Garbage Matte: Defining the Matte’s Boundaries

Drag both files from the Project window to the Comp 1 window, with the matte debris layer on top (Figure 6.4). Clear the pointer in the Timeline window to verify that the matte layer of debris does not interfere with the movement path of the characters in the movie.

The Garbage Matte in Motion

Resize and place the solid layer as close to the actors' right side as possible. Move the solid layers to follow the actors' motion path to close off the exposed area of ​​the edge of the chroma sail.

Preparing Frames for Rotoscoping

Jump into Photoshop so you can start the frame rotoscoping (Figure 6.10), and save the new file as a Photoshop document.

Your File Really Isn’t Too Big

You can now export the file as a QuickTime movie by selecting File > Export >. After clicking the OK button, a dialog box appears where you can set the compression and color depth of the QuickTime movie.

Bringing Matte Techniques Together

Roto Sequences: In and Out Blue Screen Matte Rotoscoping Stabilizing and Rotoscoping Old Films Tinting Old Films with Photoshop Layers.

Roto Sequences: Getting In and Out

Simple Roto Removal

Use a large 65-pixel soft-edged brush with the Eraser Tool to remove all but a general area around the jacket (Figure 7.5). Use a large, soft-edged brush with the eraser tool to remove all material except for a general area covering the jacket.

Blue-Screen Matte Rotoscoping

Export the original as an uncompressed QuickTime movie to match the original matte movie. Use the Clone Stamp tool to fill in the missing details of the shadow areas.

Stabilizing and Rotoscoping Old Movies

If the tracker looks fine after analyzing the film, click the Apply button. On each layer, use the Clone Stamp tool with brushes of different sizes to carefully remove dirt, dust and scratches in the frame (Figure 7.13).

Colorizing Old Movies with Photoshop Layers

At Frame 1 in the Timeline, hide layers 3 and 4, because those cars are not yet in the frame. Starting with Layer 2 in Frame 1, the beige car is in the center of the frame.

Blue versus Green Screen

Green Screen Materials

If you're on a budget (who isn't these days?) and can't afford a $60 gallon of paint, you can substitute a poor man's version of a blue/green screen. If you are lucky enough to find large pieces (or rolls) of matte-finish coated paper that come close to the PMS colors described earlier, they might work.

Lighting the Green Screen and Subjects

To better demonstrate this type of simple studio setup, I created a virtual environment in After Effects using 3-D layers and a fake green screen stage. I placed one subject, a guy in a straitjacket, back in the light of the green screen (Figure 8.5).

Matching the Subject Lighting to the Composition Environment

If you have the standard version of After Effects, your choices for blue screen keys are quite limited. The Professional Bundle version of After Effects 7 comes with a very powerful professional chroma keying plugin called Keylight.

Keylight

Removing Chroma Spill from Details

For this example, simply increasing Despill Bias from 0.0 to 25.0 seemed to eliminate most of the unwanted color cast without removing the natural colors of the character's skin and hair color. Finally, I moved the edge Saturation down to 0.0, which eliminated most of the color bleed in the hair (Figure 9.4).

Ultimatte AdvantEdge

Applying a Chroma Clean Plate

Clicking the More button brings up advanced settings at the bottom of the screen; select the Inputs tab and unhide the Clean Plate layer (Figure 9.12) to see your sample. You can make a comparison between the final composition and the original foreground layer or mattes at any time by selecting the dual screen button in the bottom left of the user interface or by selecting the split screen button and dragging the handle back and forth on the screen to see the preview (Figure 9.13).

Using Ultimatte in a Production Composition

Since the background was not completely clean and error-free, I had to use the Add Overlay tool on the noisy areas (Figure 9.16). I used the Remove Spill tool to get rid of any blue or crimson on the edges of the players' backs (Figure 9.17).

I then rotated the Primary Matte arrow and opened the Background and Foreground sliders and dragged the sliders to fill the background and foreground areas with matte (Figure 9.21). I turned down the Color Correct arrow, opened the Red and Blue settings (Figure 9.22) and used the sliders to decrease the amount of blue while increasing the amount of red in the layer.

Primatte Keyer

Tài liệu tham khảo

Tài liệu liên quan

+ Tổ chức hội nghị, hội thảo về xúc tiến đầu tƣ du lịch Việt Nam tại các thị trƣờng trọng điểm và thị trƣờng tiềm năng. + Tham gia hội thảo, hội nghị quốc tế về xúc